Yamaha Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Folks, please help me with this problem. The G22E would run, then slow to a crawl. When the accelerator is pushed repeatedly, the cart may pick up and go.
So I bought a new accelerator pedal sensor, now ran for a minute then quite. Pushed back into the garage.

What could possibly be wrong? Batteries ok (50.8v), key on, etc.
Thanks in advance for any/all help
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thank you so much. I will attempt to get this testing done. Also trying to find a Yamaha dealer nearby.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I gave up and replaced the motor, controller and solenoid. Now, the throttle pedal goes down about half way before it moves the cart. I had already replace the throttle sensor, but now wonder what could be wrong. Does the throttle adjustment need to be changed to shorten the throw?
 

·
Administrator "Loose Nut" - From Houston, Texas
Joined
·
129 Posts
The first thing to check is the linkage that activates the throttle sensor. It's a threaded rod that hooks to the accelerator pedal, hopefully the "jam/lock" nuts have come loose, not alowing the correct "throw"
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
The first thing to check is the linkage that activates the throttle sensor. It's a threaded rod that hooks to the accelerator pedal, hopefully the "jam/lock" nuts have come loose, not allowing the correct "throw"
As a follow up, I replaced all and the cart runs GREAT!. Much faster, no slowing on hills. However, the throttle pedal is still very sensitive. Adjustments made to the throw, but very sensitve to accelleration. Barelt touch the pedal and the cart jumps forward. Wish I could fix this issue.
 
1 - 6 of 6 Posts
Top