Yamaha Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
So was having a problem starting the jetski up until yesterday. I took the air filter off and sprayed a little carb cleaner in there and she started right up after sitting for a couple of hours. I have some power tune I might run through it also. But NEW ISSUE! Now for some reason it appears stuck in forward gear. I feel like I might break something trying to force it but this is definitely new. Its also only running 49 now instead of the 64 it had been running just prior to the starting issue. Is there any type of mode the jetski goes into to govern what gear it can shift into and what rpm it can run at? I've heard about these "Limp" modes but this is more like a really quick jog, not a limp.
 

·
Moderator
Joined
·
416 Posts
So was having a problem starting the jetski up until yesterday. I took the air filter off and sprayed a little carb cleaner in there and she started right up after sitting for a couple of hours. I have some power tune I might run through it also. But NEW ISSUE! Now for some reason it appears stuck in forward gear. I feel like I might break something trying to force it but this is definitely new. Its also only running 49 now instead of the 64 it had been running just prior to the starting issue. Is there any type of mode the jetski goes into to govern what gear it can shift into and what rpm it can run at? I've heard about these "Limp" modes but this is more like a really quick jog, not a limp.
Just look over the shifting rods..ect...maybe something is bent. If it has a cable it could be corroded. I've had boat shift cables corrode where the water gets in the end. They seem to last about 10 years tops then start to rust. That machine is old so corrosion is very likely.
Lube anything that had to do with the shifting also.
 
1 - 3 of 3 Posts
Top