No Oil In Dry Sump - 2007 FX HO - Yamaha Forums
Welcome to the unofficial Yamaha Forums community! Please Register to gain full access and remove the Ads! it's FREE!    
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-25-2020, 08:36 AM Thread Starter
 
Join Date: May 2020
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
No Oil In Dry Sump - 2007 FX HO

I have a 2007 Waverunner FX HO and oil is draining from the dry sump tank into the engine when sitting for a few days. No leaks and once engine is started, the oil will refill in the sump and oil level is correct. However, a couple of days later, sump will be completely dry again. I have another identical model and sump does not drain. Is there some type of check valve that keeps oil in the sump tank? Has anyone ever seen this before? When I first start the ski, I get an alarm since no oil in tank but then restart and all is fine. Have searched on-line with no help. Other than that, ski runs great.
rcduval is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome