Vstar 950 - Yamaha Forums
Welcome to the unofficial Yamaha Forums community! Please Register to gain full access and remove the Ads! it's FREE!    
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-29-2020, 04:02 PM Thread Starter
 
Join Date: Jun 2020
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Vstar 950

I have a 2009 vstar 950. When I used to turn the key on, I could hear something engraving before trying to start. Is this the fuel pump? Now, I don’t hear it engaging and the bike won’t crank.
Newaite92 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-29-2020, 07:31 PM
 
Join Date: Aug 2019
Posts: 210
Thanks: 0
Thanked 17 Times in 17 Posts
Quote:
Originally Posted by Newaite92 View Post
I have a 2009 vstar 950. When I used to turn the key on, I could hear something engraving before trying to start. Is this the fuel pump? Now, I don’t hear it engaging and the bike won’t crank.
Yes, kind of a whine noise? Most likely the fuel pump.

First give a good look over for any wires loose, corroded, whatever, then check the fuses. Hopefully you will find something simple like a bad fuse or connection.

Check near/at the battery for corrosion for sure. Batteries let off acidic gases that love to eat up copper wires.

Check all connections, unplug, check for corrosion, clean as necessary, plug back in...

You get the idea I'm sure.

Let us know what you find.
Warrior_Scott is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome