Yamaha G8 - Yamaha Forums
Welcome to the unofficial Yamaha Forums community! Please Register to gain full access and remove the Ads! it's FREE!    
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-16-2020, 07:16 PM Thread Starter
 
Join Date: Oct 2020
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Yamaha G8

I have what I thought was a G9 I have a Yamaha G8 golf cart I took the motor out rebuilt it put all new gaskets new piston head new rings got the motor back in the golf cart started it up got it going ran fairly well no muffler on it or nothing just I mean it ran we checked it ran fine the next day I come over back it out of the barn it Putt-Putt putts and then dies and then now will not start back up I've checked the coil the spark plug the only two things left are the carburetor and CDI box or igniter box if anybody else could help it would be great thank you
Bruno546 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome